Eclipse update problem

HackForum

Eclipse update problem#
Dobrý den, mám eclipse 3.8 v elementary OS. Když v eclipsu v menubaru kliknu na help/check for updates, ukáže se mi tabulka, že můžu updatovat:

Object Teams Patch for JDT/Core 2.0.2.201202051448
Eclipse Platform 3.7.2.M20120208-0800

Když zaškrtnu všechno (nebo jen jednu věc) a dám install. Tak mi vyhodí tohle:

'Updating software' has encoutered a problem.
an error encouteres while installing.

An error occurred while uninstalling
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engin
e.phases.Uninstall, operand=[R]org.eclipse.platform_root 3.8.1.dist-A8F8_IVRG4VZSCmeloKVfCrtIFotGyJZ
cMPL9 --> null, action=org.eclipse.equinox.internal.p2.touc
hpoint.natives.actions.CleanupzipAction).
Backup of file /usr/lib/eclipse/.eclipseproduct failed.
File that was copied to backup could not be deleted: /usr/lib/eclipse/.eclipseproduct

Prosím, poraďtemi co mám dělat abych úspěšně eclipse aktualizoval...
(odpovědět)
java | 37.44.16.*25.2.2016 7:46
re: Eclipse update problem#
Ahoj,
pokoušel jsem nalézt řešení, ale ta samá chyba..


chyba:
"Object Teams Patch for JDT/Core" is not applicable to the current configuration and will not be installed.
update: Object Teams Patch for JDT/Core 2.1.1.201209011847


vysvětlení viz. [link]

'The JDT Core infrastructure has no built-in JDK version dependencies'

Můžeš to zkusit celé smazat 'apt-get purge eclipse*', pak začít používat instalace ze stránek Eclipse.org dle svého uvážení..

odzkoušeno na Kali 2.0
download: [link]


tar xvf eclipse-inst-linux64.tar.gz
cd eclipse-installer
./eclipse-inst

Instalovat třeba do /opt/eclipse ..

Potom lze doinstalovat nejspíše všechno, přes položku install new software :)

about:

Eclipse IDE for Java Developers
Eclipse IDE for C/C++ Developers

Version: Mars.1 Release (4.5.1)
Build id: 20150924-1200

(odpovědět)
Mrk | 5.135.158.*26.2.2016 13:38

Zpět
 
 
 

 
BBCode